Modbus Slave — настройка и ошибки

Просмотр 15 сообщений - с 1 по 15 (из 34 всего)
  • Автор
    Сообщения
  • #20640
    manjey73
    Участник
    2021-08-30 12:53:57 Загрузка шаблона устройства из файла Slave_LinScada.xml
    2021-08-30 12:53:57 Ошибка при выполнении действий КП 5 "ModbusSlave" при добавлении КП на линию связи: Method not found: int Scada.Comm.Devices.Modbus.Protocol.ModbusUtils.GetElemCount(Scada.Comm.Devices.Modbus.Protocol.ElemType)

    В чем прикол? куда копать? вроде как 5.8.3 установлена и все от нее.

    #20641
    manjey73
    Участник

    КП источника данных устанавливается отличным от нуля, чтобы транслировать значения входных каналов, полученных от другого устройства, в стороннюю систему. Если драйвер используется для взаимодействия с реальным прибором, этот параметр должен быть равен 0.

    Я хочу транслировать другой КП, указание его номера ни к чему не приводит.

    Что должно быть в самом КП для Modbus Slave? входные каналы — как настраивать?

    #20642
    manjey73
    Участник

    КП Modbus Slave имеет номер 5
    Хочу транслировать КП с № 3.
    Указал в качестве адреса 3

    Теперь результат такой

    2021-08-30 13:28:18 Загрузка шаблона устройства из файла Slave_LinScada.xml
    2021-08-30 13:28:18 Ошибка при выполнении действий КП 5 "ModbusSlave" при добавлении КП на линию связи: Method not found: int Scada.Comm.Devices.Modbus.Protocol.ModbusUtils.GetElemCount(Scada.Comm.Devices.Modbus.Protocol.ElemType)
    2021-08-30 13:28:28 Запуск линии связи 5 "Modbus_Slave"
    

    и далее

    2021-08-30 13:29:14 Обработка входящего запроса, удалённый адрес: 10.0.0.73
    Приём (7/7): 00 01 00 00 00 06 03
    Приём (5/5): 04 00 00 00 01
    OK!
    Ошибка: КП с адресом 3 не найден

    Пытаюсь читать версией 5.8.2 а на Linux стоит 5.8.3.

    Что за КП с адресом 3 такое ????

    #20643
    manjey73
    Участник

    Похоже часть ошибок в KpModbus тянется давно, или добавили новые… На Linux на данный момент установлена библиотека KpModbus которая Update из другой темы, поведение необъяснимо….

    #20644
    manjey73
    Участник

    Похоже в KpModbusSlave те же грабли.
    Установлена галочка «Привязан к Серверу» в настройках линии связи «Опрос КП»
    В БД указан Адрес 1, в настройках Коммуникатора Адрес 3.

    Проверяется адрес 3, вместо адреса 1.

    2021-08-30 13:38:20 Обработка входящего запроса, удалённый адрес: 10.0.0.73
    Приём (7/7): 00 04 00 00 00 06 03
    Приём (5/5): 04 00 00 00 01
    OK!
    Запрошено КП с адресом 3
    Запрошено регистров: 1. Найдено элементов: 0. Привязаны к входным каналам: 0
    2021-08-30 13:39:20 Отключение клиента 10.0.0.73
    #20645
    manjey73
    Участник

    Ну и ошибка о не найденом методе никуда не делась, так и висит.

    #20646
    manjey73
    Участник

    Короче Modbus Slave не работает 🙁

    #20647
    manjey73
    Участник

    Сразу вопрос в догонку, а каким образом транслировать только часть входных каналов другого КП ?
    Не вижу каким способом вообще настроить например 141, 142, 150,151 входные каналы того же КП 3, чтобы их адреса в Modbus были 0,1,2,3

    #20648
    Mikhail
    Модератор

    Добрый день!
    В первую очередь нужно решить проблему с Method not found. Для работы KpModbusSlave использует KpModbus. Скорее всего, нужно обновить KpModbusSlave, я проверю и выложу ссылку на скачивание в этой теме.

    #20649
    Mikhail
    Модератор
    #20650
    Mikhail
    Модератор

    Сразу вопрос в догонку, а каким образом транслировать только часть входных каналов другого КП ?

    Вы можете запрашивать только те регистры, которые нужны. Запросы к КП Modbus Slave не обязательно должны совпадать с шаблоном.

    #20651
    manjey73
    Участник
    2021-08-30 16:38:10 Обработка входящего запроса, удалённый адрес: 10.0.0.73
    Приём (7/7): 00 01 00 00 00 06 01
    Приём (5/5): 03 00 8D 00 01
    OK!
    Запрошено КП с адресом 1
    Запрошено регистров: 1. Найдено элементов: 0. Привязаны к входным каналам: 0

    Почему найдено элементов 0 ? и Привязанных к входным каналам 0 ?

    #20652
    manjey73
    Участник

    Так, прием пошел, НО. Я запрашивал регистр 141, а в шаблоне на слейв был указан регистр 0. Почему «Ошибка связи» а не «Нет такого регистра» ?

    Значение канала 0, хм, сейчас проверю, что там вообще должно быть….
    Действительно 0, копаю дальше

    • Этот ответ был изменен 1 месяц, 3 недели назад от manjey73.
    • Этот ответ был изменен 1 месяц, 3 недели назад от manjey73.
    #20655
    manjey73
    Участник

    Ну вот и вопрос, есть 40 переменных в КП № 3, из них мне надо передать ну скажем 10, причем в рваном режиме. То есть в слейве это в разных местах. Надо сформировать пакет переменных из 10-ти штук для одного запроса со стороны мастера.

    Так понимаю сейчас это НИКАК, то есть нет привязки номера канала из КП №3 с адресу регистра

    • Этот ответ был изменен 1 месяц, 3 недели назад от manjey73.
    #20656
    manjey73
    Участник

    И так понимаю так же нельзя надергать входных каналов из разных КП при необходимости…

Просмотр 15 сообщений - с 1 по 15 (из 34 всего)
  • Вы должны авторизироваться для ответа в этой теме.