Astra-Linux 1.7 ошибка control.tar.zst

Просмотр 12 сообщений - с 1 по 12 (из 12 всего)
  • Автор
    Сообщения
  • #31833
    Vi
    Участник

    Ошибка при установке в Astra-Linux 1.7:
    tester@astra-1-7-3:~/Scada/rapidscada_6.2.1_linux_ru_distr$ sudo dpkg -i rapidscada_6.2.1-1_all.deb
    [sudo] пароль для tester:
    dpkg-deb: ошибка: в архиве «rapidscada_6.2.1-1_all.deb» используется неизвестное метод сжатия для «control.tar.zst», прекращаем
    dpkg: ошибка при обработке архива rapidscada_6.2.1-1_all.deb (—install):
    dpkg-deb —control subprocess returned error exit status 2
    При обработке следующих пакетов произошли ошибки:
    rapidscada_6.2.1-1_all.deb

    Проверял — sudo apt install libzstd1, sudo apt install zstd и sudo apt install tar — НЕ ПОМОГЛО
    ( Пришлось по инстукции вручную — самосвалом )
    А вот в Ubuntu 22.04 всё устанавливается (web-сервер работает, Administrator пересылает проект …)

    #31834
    manjey73
    Участник

    имхо, Астра это недоЛинукс. Держитесь от него подальше, если есть возможность 🙂
    з.ы. не связано именно со Scada, просто в ней пакеты старье и вероятно очень много.

    #31853
    Mikhail
    Модератор

    Добрый день!
    Дело в том, что Astra Linux 1.7 был выпущен несколько лет назад, и его пакеты могли устареть. По ссылке сказано, что версия пакета dpkg должна быть выше 1.21.18. Проверьте версию пакета командой
    dpkg -l dpkg

    Попробуйте обновить командами

    sudo apt update
    sudo apt upgrade

    Напишите, поможет или нет. Если не поможет, придумаем, как обойти.

    #31854
    Mikhail
    Модератор

    AstraLinux обычно ставят на объектах инфраструктуры и выбор ОС при этом не большой.

    #31856
    manjey73
    Участник

    У меня Орел 2.12.44 и в нем масса старых пакетов. Пробовал на нем собрать одну библиотеку и не смог из-за этого.
    Scada устанавливать не пробовал, надо будет как-нибудь…

    dpkg версия
    ii dpkg 1.18.24 amd64 Debian package management system

    то есть ниже чем указали выше.

    • Этот ответ был изменен 1 месяц, 3 недели назад от manjey73.
    • Этот ответ был изменен 1 месяц, 3 недели назад от manjey73.
    #31862
    JurasskPark
    Участник

    Screenshot-20240317-122451
    На виртуалку ставил, чтобы драйвера проверять под Линуксом.

    #31863
    a80808
    Участник

    Как интересно: в «Сведениях о системе» — «Память 7,7 ГиБ ОЗУ»…

    Это в Линуксе так или особенность этой системы? )))

    #31866
    JurasskPark
    Участник

    Это в Линуксе так или особенность этой системы? )))

    parametrs-wm

    Честно не знаю.

    #31934
    manjey73
    Участник
    sudo apt update
    sudo apt upgrade

    не помогает, систему не хочется апгрейдить что-то 🙂
    Какой еще способ обхода?

    1.19.8 amd64 Debian package management system

    • Этот ответ был изменен 1 месяц, 2 недели назад от manjey73.
    #31936
    manjey73
    Участник

    руками поставил 🙂

    #31937
    Mikhail
    Модератор

    > не помогает, систему не хочется апгрейдить что-то
    То есть версия пакета увеличилась, но недостаточно, правильно я понял?

    Если нужно, я могу собрать по-старому и выложить deb-пакет — напишите тогда.

    • Этот ответ был изменен 1 месяц, 2 недели назад от Mikhail.
    #31941
    manjey73
    Участник

    Да не, думаю не столько обязательно, если всегда можно поставить руками.
    Это другой ПК, там уже Debian Buster

    • Этот ответ был изменен 1 месяц, 2 недели назад от manjey73.
Просмотр 12 сообщений - с 1 по 12 (из 12 всего)
  • Вы должны авторизироваться для ответа в этой теме.