Экспорт в БД — сбой при отсутствии связи

Стартовая страница Форумы Ошибки в работе Экспорт в БД — сбой при отсутствии связи

Просмотр 14 сообщений - с 1 по 14 (из 14 всего)
  • Автор
    Записи
  • #44559
    baur
    Участник

    Добрый день,

    Начиная с версии RS5 нас преследует ошибка в модуле экспорта в БД. Если связь с базой данных отсутствует длительное время, после восстановления соединения модуль откатывается назад (по времени) и начинает повторно записывать данные.

    в версии 5 процесс восстановления занимал очень много времени, лечился остановкой сервера и ручной правкой файла ModDbExport_001_State.xml.

    В версии 6 ситуация немного изменилась: модуль тоже может откатиться назад, но затем достаточно быстро догоняет актуальное состояние. Однако появилась другая проблема — иногда модуль просто останавливается.

    тут модуль остановился в 2026-08-18 02:21:06 пока не дергал утром.

    Длинные трейсы сократил.

    MSSQL

    2026-08-18 02:20:43 Error connecting to DB:
    Microsoft.Data.SqlClient.SqlException (0x80131904): A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 — Could not open a connection to SQL Server)
    —> System.ComponentModel.Win32Exception (53): Не найден сетевой путь.

    ClientConnectionId:00000000-0000-0000-0000-000000000000
    Error Number:53,State:0,Class:20
    2026-08-18 02:21:06 Error connecting to DB:
    Microsoft.Data.SqlClient.SqlException (0x80131904): A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 — Could not open a connection to SQL Server)
    —> System.ComponentModel.Win32Exception (5): Отказано в доступе.

    ClientConnectionId:00000000-0000-0000-0000-000000000000
    Error Number:5,State:0,Class:20
    2026-08-18 02:21:07 Outdated historical data removed from the queue
    2026-08-18 08:12:29 Exporter «[1] Центральный сервер АСУТП» is stopped
    ———————————————————————————
    ———————————————————————————
    2026-08-18 08:12:39 Exporter «[1] Центральный сервер АСУТП» started

    PostgreSQL

    System.Net.Sockets.SocketException (0x00002AF9): Этот хост неизвестен.
    at System.Net.Dns.GetHostEntryOrAddressesCore(String hostName, Boolean justAddresses, AddressFamily addressFamily, Nullable`1 startingTimestamp)

    2026-08-18 02:21:05 Error connecting to DB:
    System.Net.Sockets.SocketException (0x00002AF9): Этот хост неизвестен.
    at System.Net.Dns.GetHostEntryOrAddressesCore(String hostName, Boolean justAddresses, AddressFamily addressFamily, Nullable`1 startingTimestamp)

    2026-08-18 02:21:06 Outdated historical data removed from the queue
    2026-08-18 08:12:29 Exporter «[4] asutpdb_RapidScada» is stopped
    ———————————————————————————
    ———————————————————————————
    2026-08-18 08:12:39 Exporter «[4] asutpdb_RapidScada» started

    #44560
    manjey73
    Участник

    Сервак уходит в стоп, пока вы руками его не запустите?
    З.ы. насущный вопрос для меня.

    #44569
    Mikhail
    Модератор

    Добрый день!

    Однако появилась другая проблема — иногда модуль просто останавливается.

    Останавливается отдельный экспортёр? Другие экспортёры и Сервер продолжают работать?

    #44576
    baur
    Участник

    доступные базы работали

    #44577
    baur
    Участник

    Сервак уходит в стоп, пока вы руками его не запустите?

    не сервер а экспорт данных для не доступной базы, долго пинает потом остановится, как понял доступные базы работали, экспорт данных шел

    #44578
    baur
    Участник

    думаю для симуляции надо надолго остановить базу на действующий экспорт

    #44581
    Mikhail
    Модератор

    На каких СУБД проявляется проблема? Есть ли такое, что на одной базе данных соединение восстанавливается после сбоя, а на другой начинает работать только после перезапуска?

    #44582
    baur
    Участник

    из лога видно экспорт оба бд остановились одновременно
    Postgres mssql

    #44583
    baur
    Участник

    Но реальные клиенты были только mssql поэтому не могу точно сказать как повел себя postgres, но по логу оба пишет

    2026-08-18 02:21:06 Outdated historical data removed from the queue

    После этого данные в данные в mssql пришли только после перезагрузки модуля хотя сеть был восстановлен до этого

    #44592
    Mikhail
    Модератор

    Правильно ли я понял проблему — база данных уже доступна, но модуль экспорта не восстанавливает соединение с ней? А при перезапуске Сервера, соединение тут же восстанавливается.

    #44593
    Mikhail
    Модератор

    > 2026-08-18 02:21:06 Outdated historical data removed from the queue
    Данные в очереди экспорта удаляются через заданное время, если соединение с БД не восстановилось.

    #44606
    baur
    Участник

    модуль экспорта не восстанавливает соединение с ней

    Да, случай с логом именно так, связь уже восстановился но модуль нет, начал работать только после перезапуска

    По крайней мере ситуация выглядела так, специально не проверил статус, а надо было все фиксировать …

    Но откат назад по времени это точно есть

    #44617
    Mikhail
    Модератор

    Давайте сделаем так:
    1. В этом году планируется обновить зависимости всех клиентских библиотек для подключения к БД.
    2. После обновления попробуем совместными усилиями воспроизвести проблему и, если получится воспроизвести, решить её.

    #44627
    baur
    Участник

    Хорошо ждем релиза

Просмотр 14 сообщений - с 1 по 14 (из 14 всего)
  • Для ответа в этой теме необходимо авторизоваться.