Стартовая страница › Форумы › Ошибки в работе › Экспорт в БД — сбой при отсутствии связи
- В этой теме 13 ответов, 3 участника, последнее обновление 3 недели, 3 дня назад сделано
baur.
-
АвторЗаписи
-
18.08.2026 в 06:50 #44559
baurУчастникДобрый день,
Начиная с версии RS5 нас преследует ошибка в модуле экспорта в БД. Если связь с базой данных отсутствует длительное время, после восстановления соединения модуль откатывается назад (по времени) и начинает повторно записывать данные.
в версии 5 процесс восстановления занимал очень много времени, лечился остановкой сервера и ручной правкой файла ModDbExport_001_State.xml.
В версии 6 ситуация немного изменилась: модуль тоже может откатиться назад, но затем достаточно быстро догоняет актуальное состояние. Однако появилась другая проблема — иногда модуль просто останавливается.
тут модуль остановился в 2026-08-18 02:21:06 пока не дергал утром.
Длинные трейсы сократил.
MSSQL
2026-08-18 02:20:43 Error connecting to DB:
Microsoft.Data.SqlClient.SqlException (0x80131904): A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 — Could not open a connection to SQL Server)
—> System.ComponentModel.Win32Exception (53): Не найден сетевой путь.
…
ClientConnectionId:00000000-0000-0000-0000-000000000000
Error Number:53,State:0,Class:20
2026-08-18 02:21:06 Error connecting to DB:
Microsoft.Data.SqlClient.SqlException (0x80131904): A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 — Could not open a connection to SQL Server)
—> System.ComponentModel.Win32Exception (5): Отказано в доступе.
…
ClientConnectionId:00000000-0000-0000-0000-000000000000
Error Number:5,State:0,Class:20
2026-08-18 02:21:07 Outdated historical data removed from the queue
2026-08-18 08:12:29 Exporter «[1] Центральный сервер АСУТП» is stopped
———————————————————————————
———————————————————————————
2026-08-18 08:12:39 Exporter «[1] Центральный сервер АСУТП» startedPostgreSQL
System.Net.Sockets.SocketException (0x00002AF9): Этот хост неизвестен.
at System.Net.Dns.GetHostEntryOrAddressesCore(String hostName, Boolean justAddresses, AddressFamily addressFamily, Nullable`1 startingTimestamp)
…
2026-08-18 02:21:05 Error connecting to DB:
System.Net.Sockets.SocketException (0x00002AF9): Этот хост неизвестен.
at System.Net.Dns.GetHostEntryOrAddressesCore(String hostName, Boolean justAddresses, AddressFamily addressFamily, Nullable`1 startingTimestamp)
…
2026-08-18 02:21:06 Outdated historical data removed from the queue
2026-08-18 08:12:29 Exporter «[4] asutpdb_RapidScada» is stopped
———————————————————————————
———————————————————————————
2026-08-18 08:12:39 Exporter «[4] asutpdb_RapidScada» started18.08.2026 в 08:13 #44560
manjey73УчастникСервак уходит в стоп, пока вы руками его не запустите?
З.ы. насущный вопрос для меня.18.08.2026 в 11:33 #44569
MikhailМодераторДобрый день!
Однако появилась другая проблема — иногда модуль просто останавливается.
Останавливается отдельный экспортёр? Другие экспортёры и Сервер продолжают работать?
18.08.2026 в 14:46 #44576
baurУчастникдоступные базы работали
18.08.2026 в 14:50 #44577
baurУчастникСервак уходит в стоп, пока вы руками его не запустите?
не сервер а экспорт данных для не доступной базы, долго пинает потом остановится, как понял доступные базы работали, экспорт данных шел
18.08.2026 в 15:00 #44578
baurУчастникдумаю для симуляции надо надолго остановить базу на действующий экспорт
19.08.2026 в 09:38 #44581
MikhailМодераторНа каких СУБД проявляется проблема? Есть ли такое, что на одной базе данных соединение восстанавливается после сбоя, а на другой начинает работать только после перезапуска?
19.08.2026 в 10:19 #44582
baurУчастникиз лога видно экспорт оба бд остановились одновременно
Postgres mssql19.08.2026 в 10:25 #44583
baurУчастникНо реальные клиенты были только mssql поэтому не могу точно сказать как повел себя postgres, но по логу оба пишет
2026-08-18 02:21:06 Outdated historical data removed from the queue
После этого данные в данные в mssql пришли только после перезагрузки модуля хотя сеть был восстановлен до этого
20.08.2026 в 10:55 #44592
MikhailМодераторПравильно ли я понял проблему — база данных уже доступна, но модуль экспорта не восстанавливает соединение с ней? А при перезапуске Сервера, соединение тут же восстанавливается.
20.08.2026 в 10:55 #44593
MikhailМодератор> 2026-08-18 02:21:06 Outdated historical data removed from the queue
Данные в очереди экспорта удаляются через заданное время, если соединение с БД не восстановилось.20.08.2026 в 15:25 #44606
baurУчастникмодуль экспорта не восстанавливает соединение с ней
Да, случай с логом именно так, связь уже восстановился но модуль нет, начал работать только после перезапуска
По крайней мере ситуация выглядела так, специально не проверил статус, а надо было все фиксировать …
Но откат назад по времени это точно есть
21.08.2026 в 20:20 #44617
MikhailМодераторДавайте сделаем так:
1. В этом году планируется обновить зависимости всех клиентских библиотек для подключения к БД.
2. После обновления попробуем совместными усилиями воспроизвести проблему и, если получится воспроизвести, решить её.23.08.2026 в 12:23 #44627
baurУчастникХорошо ждем релиза
-
АвторЗаписи
- Для ответа в этой теме необходимо авторизоваться.