Ошибка отправки Email через автоуправление

Стартовая страница Форумы Ошибки в работе Ошибка отправки Email через автоуправление

Просмотр 10 сообщений - с 1 по 10 (из 10 всего)
  • Автор
    Сообщения
  • #31197
    qweqweqwe
    Участник

    Добрый день!
    Столкнулся с проблемой, не отправляются письма через модуль автоуправления, в журнале линии устройства получаем

    2024-02-24 10:42:01 Команда Mail устройству [51] Отправка эл. почты
    Ошибка: недопустимая команда

    При копировании текста команды из настроек модуля команда отправляется.
    Как я понял проблема точно не в адресной книге, с настройками драйвера вроде тоже порядок, раз письма в принципе отправляются, команда из настроек автоуправления тоже правильная. Весь софт последней версии, свежескачаный. Подскажите куда ещё копать?
    Скрины настроек и журнала:




    https://ibb.co/qMLMNK5
    https://ibb.co/t46JNh9
    https://ibb.co/RDSsrNm
    https://ibb.co/G5Bqk4s

    • Эта тема была изменена 1 месяц, 2 недели назад от qweqweqwe.
    #31199
    qweqweqwe
    Участник

    Попробовал в настройках автоуправления отправлять по номеру команды, без кода — результат тот же.
    Попробовал убрать переменные из модуля автоуправления — письмо отправилось. Пробовал оставить переменную либо в заголовке письма, либо в теле, не отправляется.
    Похоже что проблема с модулем автоуправления, видимо неверный формат передачи команды от модуля в коммуникатор.
    Кстати с Telegram ситуация аналогичная.

    #31200
    a80808
    Участник

    Вот 100% работающие команды:
    Почта:
    Alarm;Мониторинг.;{Now}
    {CnlStat} Значение = {CnlVal}
    {CnlName}
    Тек.значение = {0}

    Телеграмм
    Оповещения;{Now}
    {CnlStat} Значение = {CnlVal}
    {CnlName}
    Тек.значение = {0}

    Сначала попробуйте из самого устройства через кнопку «Команда», разумеется заменив переменные на реальные значения.
    Раз до почты доходит, модуль работает правильно.

    #31201
    manjey73
    Участник

    На скрине 8 у вас два знака ; разве это правильно?

    имя_контакта;тема;сообщение;вложения

    Возможно не хватает параметров для отправки?

    У телеграм параметров меньше

    • Этот ответ был изменен 1 месяц, 2 недели назад от manjey73.
    #31207
    qweqweqwe
    Участник

    @a80808
    У вас какая версия модуля автоуправления? У меня «Модуль автоматического управления 6.0.0.4»
    Rapid SCADA 6.2.0 для Windows
    NETCore 8.0.2

    Результат тот же, при отправке через модуль автоуправления с переменными команда не работает, при отправке без переменных работает, при отправке через администратор работает.

    #31208
    qweqweqwe
    Участник

    @manjey73
    На скрине 8 отправка в устройство 51, у меня это Email. После набора необходимого количества аргументов строка перестаёт парситься и отправляется как последний аргумент, то есть текст сообщения. Проверил это на прошлой версии, на другом объекте, когда не стал заморачиваться и сделал копию оповещений с заменой Email на Telegram.

    #31209
    qweqweqwe
    Участник

    Screenshot-13
    Screenshot-14
    Screenshot-15
    Screenshot-16

    #31210
    Mikhail
    Модератор

    Добрый день!
    Подтверждаю, что Модуль автоматического управления версии 6.0.0.4 содержит ошибку при формировании текста команды. Используйте обновление по ссылке.

    #31211
    Mikhail
    Модератор

    Если Вы переносите проект с 5-й версии на 6-ю, то рекомендую сначала сохранить конфигурацию модуля с помощью версии модуля 6.0.x.x, а затем уже обновлять модуль до версии 6.1.x.x.

    #31212
    qweqweqwe
    Участник

    @mikhail Благодарю за помощь! Предложенное обновление решило проблему, команды стали отправляться корректно.
    Конфигурацию модуля несколько раз редактировал в версии 6.0.0.4 пока искал причину проблемы, перенеслось в версию 6.1.0.0 без явных проблем.

Просмотр 10 сообщений - с 1 по 10 (из 10 всего)
  • Вы должны авторизироваться для ответа в этой теме.