dnat1970

Ответы в темах

Просмотр 15 сообщений - с 16 по 30 (из 43 всего)
  • Автор
    Записи
  • dnat1970
    Участник

    Отлично!
    ….нужно скачивать ASP.NET Core Runtime 6.0.10 — Hosting Bundle. И устанавливать Hosting Bundle после установки IIS.
    Именно ее и нужно установить! В моем случае я устанавливал х64 версию и соответственно AspNetCoreModuleV2 — не инсталлировался
    Если в процессе инсталляции Scada 6 об этом говорилось — то сорри за то что потратил Ваше время, если нет — то наверное для таких как я нужно бы указать конкретнее пакет установки (например в готовящейся документации)

    Ну пока еще не все, по ссылке в браузере http://localhost:10008/Login — сайт работает, при попытке передать конфигурацию в Администраторе

    Остановка службы Вебстанции
    Команда управления службой не выполнена

    Запуск службы Вебстанции
    Команда управления службой не выполнена

    И при попытке открыть Default в Веб браузере ошибка
    Адрес Ввек станции не задан в профиле развертывания или некорректен

    Прошу помощи еще и в этом

    dnat1970
    Участник

    Запланировал установку сегодня Scada 6 — еще на один компьютер — хочу понять почему модуль не ставиться автоматически — исключить вероятность того что моя версия Windows встала некорректно
    По результатам отпишу

    dnat1970
    Участник

    Доброго времени — Спасибо
    Именно его и нет, качество картинки плохое можете прислать путь этого модуля попробую зарегистрировать в ручном режиме

    dnat1970
    Участник

    Доброго дня
    Не совсем понятно где и как посмотреть
    2.2. Открыть список модулей и убедиться, что модуль AspNetCoreModuleV2 установлен.?
    Если в диспетчере служб IIS Модули — то у меня там его нет. Как там его зарегистрировать — установить пока не понятно.Документация Microsoft говорит о том что достаточно инсталлировать пакет
    При этом пакеты
    aspnetcore-runtime-6.0.10-win-x64
    dotnet-hosting-6.0.10-win
    установлены и Диспетчер сервера IIS показывает
    Служба веб-публикаций W3SVC Выполняется Автоматически

    Можно попросить скриншот действующей службы IIS где видно что он подключен либо немного подробнее как он регистрируется если кроме инсталляции это требуется

    Но у меня все таки ощущение, что отсутствуют права на чтение файла web.config

    Вот что есть в документации на ASP.NET Core и служб IIS (https://learn.microsoft.com/ru-ru/aspnet/core/host-and-deploy/iis/advanced?source=recommendations&view=aspnetcore-6.0#aspnet-core-module-with-an-iis-shared-configuration)

    Модуль ASP.NET Core с общей конфигурацией IIS
    Программа установки модуля ASP.NET Core запускается с правами учетной записи TrustedInstaller. Поскольку учетная запись локальной системы не имеет разрешения на изменение пути к общей папке, используемого общей конфигурацией IIS, установщик получает ошибку отказа в доступе при попытке настроить параметры модуля в файле applicationHost.config общей папки.
    При использовании общей конфигурации IIS на том же компьютере, где установлены службы IIS, запустите установщик пакета размещения ASP.NET Core с параметром OPT_NO_SHARED_CONFIG_CHECK со значением 1:
    Консоль

    Копировать
    dotnet-hosting-{VERSION}.exe OPT_NO_SHARED_CONFIG_CHECK=1
    Если путь к общей конфигурации не на том же компьютере, где установлены службы IIS, выполните следующие действия.
    Отключите общую конфигурацию IIS.
    Запустите установщик.
    Экспортируйте обновленный файл applicationHost.config в общую папку.
    Повторно включите общую конфигурацию IIS.

    dnat1970
    Участник
    dnat1970
    Участник
    в ответ на: Проверка дистрибутива v6 beta #25836
    dnat1970
    Участник

    Позже установил Scada 6.0 от 2.11 на Windows Server 2022(был уже развернут и норм функционирует) подумав что у меня что то может быть с версией Win10
    Ошибки все те же

    Ошибка HTTP 500.19 — Internal Server Error
    Запрашиваемая страница не доступна из-за неверной конфигурации данных для этой страницы.

    Подробные сведения об ошибке:
    Модуль nbsp; IIS Web Core
    Уведомление неизвестно
    Обработчик Пока не определено
    Код ошибки 0x8007000d
    Ошибка конфигурации
    Файл конфигурации \\?\C:\Program Files\SCADA\ScadaWeb\web.config
    Запрошенный URL-адрес http://localhost:10008/Login
    Физический путь
    Метод входа Пока не определено
    Пользователь, выполнивший вход Пока не определено

    Настройка источника:
    -1:
    0:
    Дополнительные сведения:
    Эта ошибка возникает из-за проблем считывания файла конфигурации для веб-сервера или веб-приложения. В некоторых случаях журналы событий содержат более подробные сведения о причине возникновения ошибки.

    Прошу подсказки — где еще покапаться

    в ответ на: Проверка дистрибутива v6 beta #25835
    dnat1970
    Участник

    Доброго дня.
    Так и не могу решить проблему с установкой Веб сервера при инсталляции 6 версии от 2.11.22
    Попробовал переустановить Win 10 — и на чистый комп сделал инсталляцию — проблема осталась прежней — В момент Передачи конфигурации
    Остановка службы Вебстанция
    Команда управления службой не выполнена
    Запуск службы Вебстанция
    Команда управления службой не выполнена
    Непосредственно с IIS если запускать Scada чз Обзор веб-сайта выдаете ошибку подключения
    В консоле управления IIS не дает открывать ни какие Службы пишет Ошибку доступа \\?\C:\Program Files\SCADA\ScadaWeb\web.config Соответственно проверить — в списке модулей для созданного сайта присутствует AspNetCoreModuleV2 не имеется возможности
    То что я сделал (может не правильно) — Поставил галочки к требуемым в IIS служб в соответствии с инструкцией которая есть на сайте для предыдущей версии — для новой мне не попалось
    И IIS после инсталляции Scada появился Пул приложений ScadaAppPool изначально после инсталляции Версия среды CLR.NET устанавливается «Без управляемого кода» я ее пробовал менять на «CLR NET v.4.0.30319», то что есть еще в выпадающем списке — в обоих случаях без результатно (как правильно подскажите)

    в ответ на: Проверка дистрибутива v6 beta #25823
    dnat1970
    Участник

    Если в IIS Scada смотреть
    Основные настройки — Тест настроек
    То там есть ошибка Авторизация Не удается проверить доступ по пути (C:\Program Files\SCADA\ScadaWeb)
    Похоже что то с правами доступа
    Если кто сталкивался подскажите

    в ответ на: Проверка дистрибутива v6 beta #25822
    dnat1970
    Участник

    Если пытаться а IIS пробовать войти в файлы сайта то выдает ошибку
    Имя файла \\?\С:\Program Files\ScadaWeb\web.config
    Может что с настройками путей в IIS?

    в ответ на: Проверка дистрибутива v6 beta #25821
    dnat1970
    Участник

    Нет не открывается
    HTTP ERROR 500

    в ответ на: Проверка дистрибутива v6 beta #25819
    dnat1970
    Участник

    Удалил — перегрузил — ошибка та же
    То что порт в соединении 10000 а в IIS 10008 — не может влиять?
    Запускал HelloWorld

    в ответ на: Проверка дистрибутива v6 beta #25818
    dnat1970
    Участник

    Добавлю из наблюдения — IIS Прописал для Scada порт :10008
    В параметрах соединения Администратора стоял порт 10000
    Пробовал поменять на 10008 — не помогло ошибки те же

    в ответ на: Проверка дистрибутива v6 beta #25816
    dnat1970
    Участник

    Доброго вечера!
    Установил последнюю версию 6 от 2.11 на Win 10
    Вроде все делал в соответствии с инструкцией
    Не могу запустить и открыть Web страницу ни на HelloWorld не на вновь созданном проекте — в момент передачи конфигурации пишет
    Запуск службы Вебстанция
    Команда управления службой не выполнена
    И затем когда делаем Открыть в ВЕБ браузере — дает ошибку
    «Адрес Вебстанции не задан в профиле развертывания или некорректен»
    Прошу подсказки — где поискать чтобы исправить ошибку

    Передача конфигурации
    Размер архива: 21 109 байт

    Остановка службы Коммуникатор
    Команда управления службой выполнена успешно
    Остановка службы Вебстанция
    Команда управления службой не выполнена
    Перезапуск службы Сервер
    Команда управления службой выполнена успешно
    Запуск службы Коммуникатор
    Команда управления службой выполнена успешно
    Запуск службы Вебстанция
    Команда управления службой не выполнена

    Передача конфигурации завершена успешно

    в ответ на: Не получается экспорт в БД #25769
    dnat1970
    Участник

    Здравствуйте!
    Да, соглашусь скорее всего проблема в настройках БД, попробую откатится на ранние версии MySql и поэкспериментировать.
    В Rapid SCADA 6 Beta модуля экспорта насколько понял еще нет — подскажите, когда по срокам его планируется внедрить?
    Спасибо

Просмотр 15 сообщений - с 16 по 30 (из 43 всего)