ScadaWeb 5.2.0

Просмотр 15 сообщений - с 1 по 15 (из 30 всего)
  • Автор
    Сообщения
  • #6333
    Валдас
    Участник

    Добрый день,
    обновил Scada на новую версию 5.2.0, при загрузке схем ничего неотображает, только в в верху выскакивает надпись, при загрузке схемы произошла ошибка, попробуйте загрузить схену заного, но и при нажатии кнопки згрузить заного, нечего не меняется, пустое окно и опять попробуй загрузить заного. На локальном компютере 127.0.0.1 схемы отображаются, но таблицы неотображаются. Поменял папку ScadaWeb от старой версии, то же глюки. Браузер Mozilla вроде всё нормально версия 5.0.0.4 а вот Opera всё равно таблиц неотображает.

    Подскажите где копать, что могло изменится при установке новой версии? Перед переустановкой всё работало на всех браузерах, opera, mozilla, chrome, кроме MS Internet Explorer 11. Не могу найдти в чём проблема… В ScadaWeb\ScadaWeb.log файле нечего такого невидно.

    2017-06-29 15:22:31 <SB-***><ASP.NET v4.0><ACT> Logout: Admin. IP address: 127.0.0.1
    2017-06-29 15:22:32 <SB-***><ASP.NET v4.0><ACT> Login: Admin (Administrator). IP address: 127.0.0.1
    2017-06-29 15:22:32 <SB-***><ASP.NET v4.0><ACT> User information has been updated. IP address: 127.0.0.1. Session: xcw0enhwwtlrjyd5mwnuy3e0
    2017-06-29 15:22:54 <SB-***><ASP.NET v4.0><ACT> Logout: Admin. IP address: 10.*.*.*8
    2017-06-29 15:22:56 <SB-***><ASP.NET v4.0><ACT> Login: Admin (Administrator). IP address: 10.*.*.*8
    2017-06-29 15:22:56 <SB-***><ASP.NET v4.0><ACT> User information has been updated. IP address: 10.*.*.*8. Session: k3kzwjo3iazyhpc3ymzrfpxl
    2017-06-29 15:26:08 <SB-***><ASP.NET v4.0><ACT> Logout: Admin. IP address: 10.*.*.*8
    2017-06-29 15:26:08 <SB-***><ASP.NET v4.0><EXC> Error getting extended current data by the filter where channels= , view id=4011:
    Scada.ScadaException: User not logged on.
    at Scada.Web.UserMonitor.CheckLoggedOn(UserRights& userRights, Boolean throwOnFail)
    at Scada.Web.ClientApiSvc.GetCurCnlDataExt(String cnlNums, String viewIDs, Int32 viewID)
    2017-06-29 15:26:08 <SB-***><ASP.NET v4.0><EXC> Error getting events by the filter where channels= , view id=4011:
    Scada.ScadaException: User not logged on.
    at Scada.Web.UserMonitor.CheckLoggedOn(UserRights& userRights, Boolean throwOnFail)
    at Scada.Web.ClientApiSvc.GetEvents(Int32 year, Int32 month, Int32 day, String cnlNums, String viewIDs, Int32 viewID, Int32 lastCount, Int32 startEvNum, Int64 dataAge)
    2017-06-29 15:26:21 <SB-***><ASP.NET v4.0><ACT> Login: Admin (Administrator). IP address: 10.*.*.*8
    2017-06-29 15:26:21 <SB-***><ASP.NET v4.0><ACT> User information has been updated. IP address: 10.*.*.*8. Session: kqqjzo2xige2hvs0bk1smgls

    Ссылка — 1 Схемы нет
    Ссылка 2 — Таблиц нет

    #6345
    Mikhail
    Модератор

    Добрый день!
    Давайте для однозначности будем пробовать на Chrome. Также тестируются Firefox и Edge. IE11 не поддерживается, т.к. он не поддерживает современных стандартов JavaScript.

    Сначала нажмите в браузере Ctrl+F5 для полного обновления скриптов.
    Если это не поможет, то нажмите F12 и пришлите ошибки со вкладки Console. Проблема, вероятно, на стороне клиента, поэтому в *.log её не видно.

    #6357
    Валдас
    Участник

    Здравствуйте, да, я понимаю что на Chrome рассчитано всё, но хотелосъ чтоб и на других современных браузерах работало, на Chrome всё работает, на Опера браузере тоже работало раннее…
    а сейчас проблемы вот такие на Opera:

    utils.js:151 19:45:45 Request ‘ClientApiSvc.svc/GetEvents’ failed: 0 (error)
    logFailedRequest @ utils.js:151
    utils.js:143 19:45:46 Request ‘ClientApiSvc.svc/GetEvents’ successful
    utils.js:151 19:45:46 Request ‘ClientApiSvc.svc/GetCurCnlDataExt’ failed: 0 (error)
    logFailedRequest @ utils.js:151
    utils.js:143 19:45:47 Request ‘ClientApiSvc.svc/CheckLoggedOn’ successful
    utils.js:143 19:45:47 Request ‘ClientApiSvc.svc/GetEvents’ successful
    scheme.js:18 19:45:47 Start loading scheme
    schememodel.js:487 19:45:47 Start loading scheme
    plugins/Scheme/SchemeSvc.svc/GetSchemeDoc?viewID=5100&viewStamp=0&_=1499013947044 Failed to load resource: the server responded with a status of 404 (Not Found)
    utils.js:151 19:45:47 Request ‘SchemeSvc.svc/GetSchemeDoc’ failed: 404 (Not Found)
    logFailedRequest @ utils.js:151
    schememodel.js:110 19:45:47 Scheme loading failed
    (anonymous) @ schememodel.js:110
    scheme.js:44 19:45:47 Scheme loading failed
    (anonymous) @ scheme.js:44
    utils.js:143 19:45:48 Request ‘ClientApiSvc.svc/GetEvents’ successful
    utils.js:143 19:45:49 Request ‘ClientApiSvc.svc/GetEvents’ successful

    #6358
    Mikhail
    Модератор

    Добрый день!

    Установил Opera, открыл http://demo.rapidscada.net — работает. Т.к. на Chrome у Вас сейчас работает, а на Opera Вы использовали предыдущую версию веб-приложения, то я думаю, что нужно очистить кеш браузера и убедиться, что используется свежая версия Opera.

    Если у Вас на Opera работает демо, но не работает Ваша система, то давайте дальше разбираться.

    #6359
    manjey73
    Участник

    На Opera Demo запустилась. К сожалению сейчас нет возможности тестировать новую версию, просто время поджимает. Если получится дома на Вынь10 поставить, чтобы не быть привязанным, попробую.

    #6367
    Валдас
    Участник

    Да, очистил кеш Opera браузера и всё заработало, спасибо

    #6369
    manjey73
    Участник

    Подскажите где его очистить, и можно ли очистить для конкретного сайта ?

    #6382
    Валдас
    Участник

    Всё таки не всё работает в версии 5.2.0
    Не загружаются динамическии изображения, на секунду видны при загрузке изображения по умолчанию, а при переходе на изображения по статусу всё исчезает. Проверял, всё кажется нормально, при статусе 0 одно изображение, при статусе 1 другое, но ни чего непоказыжает, в чём может быть проблема?
    В старой версии всё работало…
    И Никаких ошибок:

    13:01:14 Request ‘ClientApiSvc.svc/GetEvents’ successful
    utils.js:143 13:01:15 Request ‘ClientApiSvc.svc/GetCurCnlDataExt’ successful
    utils.js:143 13:01:15 Request ‘ClientApiSvc.svc/GetEvents’ successful
    utils.js:143 13:01:15 Request ‘ClientApiSvc.svc/GetEvents’ successful
    schememodel.js:487 13:01:16 Start loading scheme
    utils.js:143 13:01:16 Request ‘SchemeSvc.svc/GetSchemeDoc’ successful
    utils.js:143 13:01:16 Request ‘SchemeSvc.svc/GetComponents’ successful
    utils.js:143 13:01:16 Request ‘SchemeSvc.svc/GetImages’ successful
    schememodel.js:103 13:01:16 Scheme loading completed successfully
    utils.js:143 13:01:16 Request ‘ClientApiSvc.svc/GetCurCnlDataExt’ successful
    utils.js:143 13:01:16 Request ‘ClientApiSvc.svc/GetEvents’ successful
    utils.js:143 13:01:17 Request ‘ClientApiSvc.svc/GetCurCnlDataExt’ successful
    utils.js:143 13:01:18 Request ‘ClientApiSvc.svc/GetEvents’ successful
    utils.js:143 13:01:18 Request ‘ClientApiSvc.svc/GetCurCnlDataExt’ successful

    • Этот ответ был изменен 4 года, 4 месяца назад от Валдас.
    #6383
    Валдас
    Участник

    Очистить кэш можно любого браузера, там в настройках есть что то вроде конфиденциальности и безопасности, где надо найти кнопку с надписью «Очистить историю браузера», там выбрат период за какой хотите очистить историю….

    #6385
    Валдас
    Участник

    Схема должна быть такая:
    Схема оригинал

    https://postimg.org/image/mwybprdjd/
    https://postimg.org/image/mwybprdjd/

    При загрузке:
    При загрузке

    https://postimg.org/image/q5h52vmxf/
    https://postimg.org/image/q5h52vmxf/

    • Этот ответ был изменен 4 года, 4 месяца назад от Валдас.
    #6387
    manjey73
    Участник

    Я обновил SCADA, сделал сброс браузера за последний час, подключился. Все работает.
    Картинки применял анимированный GIF при наведении и SVG для кнопок команд

    #6393
    Mikhail
    Модератор

    Если точнее, то динамическое изображение связано не со статусом, а со значением канала. Со статусом связан цвет.
    Валдас, Вы можете сделать простейшую новую схему, на которой будет только один компонент, чтобы эта схема имела такую же проблему? И прислать ссылку на файл схемы.

    #6400
    Валдас
    Участник

    Сделал простейшую новую схему, всё работало, пока не добавил в фильтр каналы (Data: Chanel filter). Удаляю каналы из фильтра изображения появляются, добавляю каналы в фильтр, изображения пропадают. Как работает этот фильтр? Я его использовал для того, чтобы в конкретной схеме события отображались только для этой схемы, а события от других схем не показывало.

    Точно, в старой схеме из фильтра удалил один канал и это изображение появилось. Например, я сделал в схеме «лампочку» — красная, когда аварийный стоп нажат, зелёная, когда всё нормально, тот же канал использую чтобы отображать события, я его прописываю в фильтр чтобы это событие отображалось только для этой схемы. Но тогда эта «лампочка» изчезает… 🙁

    • Этот ответ был изменен 4 года, 4 месяца назад от Валдас.
    #6404
    Mikhail
    Модератор

    Очень интересно.
    Фильтр как бы добавляет в схему используемые каналы. Чтобы когда выбран фильтр по представлению, соответствующие события отображались.
    Правильно ли я понял, что Вы добавляете в фильтр тот же канал, что уже используется в компоненте схемы и это приводит к ошибке отображения?

    #6415
    Валдас
    Участник

    Да Михаил, именно так и есть, я добавляю в фильтр тот же канал, что уже используется в компоненте схемы, именно в динамическом изображении, и тогда это изображение в этом компоненте исчезает при загрузке схемы.

Просмотр 15 сообщений - с 1 по 15 (из 30 всего)
  • Вы должны авторизироваться для ответа в этой теме.