Установка Rapid SCADA на Raspberry Pi 2

Стартовая страница Форумы Rapid SCADA на Linux и Raspberry Pi Установка Rapid SCADA на Raspberry Pi 2

Просмотр 15 сообщений - с 16 по 30 (из 105 всего)
  • Автор
    Сообщения
  • #10989
    АватарМакс
    Участник

    Если бы вообще весь исходный код был бы на qt было бы вообще идеально )

    #10990
    АватарМакс
    Участник

    Как я понял все настройки мне надо на видовсе сделать а потом скопировать их на линукс ?

    #10991
    MikhailMikhail
    Модератор

    Может сделать оконный интерфейс на Qt ?

    Rapid SCADA — это open source, может кто-нибудь сделает ))

    Как я понял все настройки мне надо на видовсе сделать а потом скопировать их на линукс ?

    Да, что именно копировать, написано в how_to_use.txt в дистрибутиве.

    #13491
    Аватарmaikl
    Участник

    Здравствуйте, подскажите пожалуйста что я делаю не так —у меня тоже не получается вызвать вебинтерфейс скады….при наборе в браузере 192.168.1.106:8086/scada выдаёт сообщение 192.168.1.106/login.aspx
    четыре раза по инструкции установил на линукс дистрибутивы (из файла install.txt )ни чего не выходит
    (стоит Rasbian buster)

    #13496
    Аватарtrak
    Участник

    Порт должен быть 8084 ,насколько я знаю .

    #13506
    MikhailMikhail
    Модератор

    Текущая инструкция описывает установку на Apache, у которого стандартный порт 80 (можно не указывать в адресной строку).
    Старая инструкция описывала установку на XSP4, у которого используется порт 8084.
    Уточните, какую версию Rapid SCADA Вы устанавливаете?

    #13507
    MikhailMikhail
    Модератор

    Недавно ставил на чистый Rasbian Buster — прошло нормально.
    Проверьте на всякий случай версию Моно:
    mono --version

    #13516
    Аватарmaikl
    Участник

    у меня стоит — Mono JIT compiler version 6.0.0.319
    и версия Rapid SCADA 5.7.1 Mono (размер 9,3 МБ, релиз 29.08.2019)
    и причём статус apache2 выдаёт ошибку — http://skrinshoter.ru/s/030919/Q37sBadI
    не пойму что не так???

    #13519
    MikhailMikhail
    Модератор

    На скриншоте что-то написано про ошибку синтаксиса в apache2.conf. Возможно, при настройки конфигурационных файлов Апача, закралась какая-то ошибка.

    #13522
    Аватарmaikl
    Участник

    в инструкции по установке в файле install.txt написано пункт 11. что нужно в apache2.conf добавить следующую строку <Directory /var/www/html/scada/>
    <FilesMatch «\.(xml|log|bak)$»>
    Require all denied
    </FilesMatch>
    </Directory>

    я вставил но правильно_ли???

    http://skrinshoter.ru/s/030919/dwt3RwVD

    #13540
    MikhailMikhail
    Модератор

    Есть подозрение, что проблема в окончании строк.
    Для Linux важно, чтобы строки заканчивались символом с кодом 10. А Windows обычно сохраняет с 13 и 10. Надо проверить этот момент.

    #13541
    MikhailMikhail
    Модератор

    Для пробы верните старый файл conf, если он сохранился.

    #14276
    Аватарantex
    Участник

    Написали статью про установку на raspberry.
    https://habr.com/ru/post/478484/
    Может кому-то поможет при установке Rapid Scada на малину!

    #14289
    MikhailMikhail
    Модератор

    У кого есть аккаунт на Хабре, присоединяйтесь к обсуждению. Тема интересная.

    #14710
    Аватарmanjey73
    Участник

    Михаил, зря удалили установку WEB для mono-xsp4 из описания.

    Надо быстро восстановить работу и не могу нигде найти.
    Модули Апача не хотят ставиться…

Просмотр 15 сообщений - с 16 по 30 (из 105 всего)
  • Вы должны авторизироваться для ответа в этой теме.